Flash 7.0 r2 displays as “7.0.2” when
flash.version is called. To me, this makes the most sense, since that’s what an “r2” would mean anyways. It also makes it easier when comparing Flash versions to do a
String.split() followed by a
parseInt() on a particular section of the version string.
However, I didn’t know about the occasional developer’s build, namely “Shockwave Flash 7.0 d249”. Making this return a value of “7.0.249” would be misleading and inaccurate since a developers/beta build is a precursor to a release build. Logically, I could append a “0” before the 249 (i.e. “7.0.0249”) which would work, but wouldn’t necessarily be correct.
The only way to stay truly correct would be to leave the “7.0 r2” or “6.0 r79” monikers as-is, but it makes less sense, in my opinion. So, what do you think? “7.0.x” or “7.0 rX”?